Modernizr 3.5.0

Instead of quietly updating the library like we did for our 3.4.0 release (yes, that happened — see the full changelog here), we have an exciting new feature detect as part of 3.5.0: CSS Grids!

With browsers adding support for CSS Grids in their latest releases, the time to start using CSS Grids is truly here. Just one caveat: IE11 and current shipping versions of Edge do not support the new syntax, but _do_ support the old legacy CSS Grids proposal—and only one of them supports, uh, @supports.

So in 3.5.0 we’re adding two tests in one: the now-standard official CSS Grid syntax as Modernizr.cssgrid, and the old proposal’s syntax as Modernizr.cssgridlegacy. There is also an additional polyfill available for the Pointer Events test, named PEP. Lastly, dependencies were updated.

Happy developing!

New Feature Detect(s)


Updated Dependencies